ActiveHome Pro Reinstallation

From X10Wiki
Revision as of 21:42, 4 June 2007 by Ericb (Talk | contribs)

Jump to: navigation, search

Question

What do I do if ActiveHome Pro crashes after it starts and runs correctly for several minutes?

What do I do if ActiveHome Pro crashes with an ERROR GETTING X10NET INTERFACE?

ActiveHome Pro is crashing or locking up, and I've tried other strategies mentioned on this site. How can I reinstall ActiveHome Pro?

Answer

These errors are generally due to a corrupt file of some sorts. First, please redownload the update to the latest version of ActiveHome Pro here:

ftp://ftp.x10.com/pub/applications/activehome/ahp_updt.exe

The Activehome Professional software should now operate correctly. If you receive a message that states the device is not recognized, unplug the CM15A from the wall and computer. Remove its batteries, then plug it back in to the wall and computer. The device should now be recognized by your computer. If the problems persist, you should reinstall ActiveHome Pro.

  1. Go to Control Panel | Add/Remove Programs and click on the ‘Add/Remove’ button for Activehome Pro. Note: You may receive a message saying "Could Not Find Install.Log." If you get this, delete the folder at C:\Program Files\ActiveHome Pro. Run the ActiveHome Pro installer again, and repeat Step #1.
  2. A window will pop up asking if you would like to do an ‘Automatic’ or ‘Custom’ uninstall. Select ‘Custom.’
  3. Click on the ‘Select all’ button, and then the ‘next’ button on every screen in the Uninstall Wizard.
  4. Click ‘Finish.’ Repeat steps 1-4 for X-Ray Vision, X10 Hardware, and any other X10 software installed.
  5. Reboot the computer.
  6. Open "My Computer". Go to C:\Program Files\Common Files.
  7. Delete the X10 folder. If you receive a message that states you cannot delete this folder, go to step 8. If you can delete it, go to step 12.
  8. If you are using Windows 98 or ME, skip to step 9. Go into the Start menu and select Run. Type NET STOP X10NETS and hit Enter. Skip step 9; proceed to step 10.
  9. Hit Ctrl-Alt-Del, select X10NETS.EXE, and End Task.
  10. Delete the X10 folder in the Common Files folder.
  11. If this does not work, reboot the computer and repeatedly press F8 while it loads to bring up the Safe Mode menu. Boot into Safe Mode and delete the X10 folder in the Common Files folder.
  12. Go into C:\Documents and Settings\All Users\Application Data. Delete the Active Home Professional folder and the X10 Settings folder.
  13. Reboot the computer and disconnect your CM15A ActiveHome Pro Interface.
  14. Install the ActiveHome Pro software, and plug in the CM15A when prompted.
  15. Reboot the computer again.

The ActiveHome Professional software should now operate correctly. If you receive a message that states the device is not recognized, unplug the CM15A from the wall and computer. Remove its batteries, then plug it back in to the wall and computer. The device should now be recognized by your computer.