ActiveHome Pro Reinstallation For Windows 7

From X10Wiki
Jump to: navigation, search

Question

What do I do if ActiveHome Pro crashes after it starts and runs correctly for several minutes?

ActiveHome Pro is crashing or locking up, and I've tried other strategies mentioned on this site. How can I reinstall ActiveHome Pro?

Answer

These errors are generally due to a corrupt file of some sorts. First, please redownload the update to the latest version of ActiveHome Pro here: COMING SOON!


The Activehome Professional software should now operate correctly. If you receive a message that states the device is not recognized, unplug the CM15A from the wall and computer. Remove its batteries, then plug it back in to the wall and computer. The device should now be recognized by your computer. If the problems persist, you should reinstall ActiveHome Pro. Make sure you download the latest version: COMING SOON!


1) Go to Control Panel | Under ‘Programs’ selcect ‘Uninstall Programs’ then double click on Activehome Pro and walk through the uninstall wizard. Note: You may receive a message saying "Could Not Find Install.Log." If you get this, delete the folder at C:\Program Files\ActiveHome Pro. Run the ActiveHome Pro installer again, and repeat Step #1.

2) A window will pop up asking if you would like to do an ‘Automatic’ or ‘Custom’ uninstall. Select ‘Custom.’

3) Click on the ‘Select all’ button, and then the ‘next’ button on every screen in the Uninstall Wizard.

4) Click ‘Finish.’

5) Reboot the computer.

6) Open "My Computer". Go to C:\Program Files\Common Files.

7) Delete the X10 folder. If you receive a message that states you cannot delete this folder, go to step 8. If you can delete it, go to step 12.

8) Go into the Start menu and select Run. Type NET STOP X10NETS and hit Enter.

9) Delete the X10 folder in the Common Files folder.

10) If this does not work, reboot the computer and repeatedly press F8 while it loads to bring up the Safe Mode menu. Boot into Safe Mode and delete the X10 folder in the Common Files folder.

11) Go into C:\Users\All Users\AppData. The AppData folder may be hidden.) Delete the Active Home Professional folder and the X10 Settings folder.

12) Reboot the computer and disconnect your CM15A or CM19A ActiveHome Pro Interface.

13) Install the ActiveHome Pro software; plug in the CM15A or CM19A when prompted.

14) Reboot the computer again.

The ActiveHome Professional software should now operate correctly. If you receive a message that states the device is not recognized, unplug the CM15A from the wall and computer. Remove its batteries, then plug it back in to the wall and computer. The device should now be recognized by your computer.