Resolving WiFi Connection Issues

From X10Wiki
Jump to: navigation, search

Question

Why can't I connect to ActivePhone, iWatchMobile, or OnAlertMobile from my phone?

Answer

Please go through this step-by-step checklist.

1) Verify WiFi phone

Make sure your smartphone can connect to WiFi networks and that it has an HTML4-compatible web browser. A Google search for MAKE MODEL# SPECIFICATIONS can help a lot with this.


2) Verify WiFi connected

Email a link from your server PC to your phone or to any other email account you have. This link will usually begin with 192.168 or 10 ; an example would be http://192.168.1.8:8777/ahp . Take the first three numbers, change the fourth one to 1, and remove the rest: for example, 192.168.1.1 . Go to that address on your server PC. You should see a login page for your router. Go to the same address on your phone; you should get the same login page. If you do not, then your phone is not connected to your WiFi network.


3) Test on server PC

On your server PC, go to one of these addresses in your Web browser:


You should be able to load the remote client on your server PC at one of those addresses.

If you get a "Server did not respond" error, please go through this procedure then reboot your PC.


4) Test on the phone

Try to visit the link you emailed to your phone in step 2. If you cannot access the remote client, you should get an error message:

"Server did not respond"

  • Blackberries must use the Hot Spot browser to connect using the WiFi link. The default browser will be unable to find any address on your local WiFi network. The 3G link should work with both the default and the Hot Spot browser.
  • Many home routers use Dynamic IP addressing, and it is possible the address of your PC has changed because of this. Double check the link you are using matches the link in the Invite Cellphone Dialog.
  • If the link does match, this generally indicates that a firewall or other security software on your PC is blocking the connection. Reboot your PC, shut down any firewalls, and try again.

"Error 500"

  • Check your Reflector Connection status in the Invite Cellphone Dialog. If the status is red, then your PC is not connected to the reflector. Make sure you are connected to the internet, and no firewalls or other security programs are blocking ActiveHome Pro.
  • Try resetting the security key to fix a broken connection. This will change your Xid for all mobile plugins so be sure to update your links after this step.
  • Which version of ActiveHome Pro are you running? Check Help-About... The latest version of the software is 3.318, and running earlier versions of the software can cause this error. You can download the latest version of ActiveHome Pro here.