Getting ActiveHome Pro Started and Working

From X10Wiki
Jump to: navigation, search

Introduction

This guide should help you get started quickly with the X10 ActiveHome Pro system.

Setup

Connect the ActiveHome USB Interface

The first step in using ActiveHome Pro is connecting the ActiveHome Pro USB Interface. To install it, follow these steps:

  • Connect the supplied USB cable in the ActiveHome USB Interface (CM15A).
  • Plug the other end of the USB cable into a USB port on your computer.
  • Plug the Interface directly into a wall outlet. Do not plug it into a power strip.
  • Put four (4) AAA batteries into the interface battery compartment and replace the cover.

Troubleshooting the Interface Connection

If the interface is not connected, or ActiveHome Pro is not able to communicate with it, the software will tell you the interface is not connected, and the "no interface" icon will appear on the ActiveHome Pro Status Bar. If this happens, check the connections above. Make sure that the interface's outlet has power, and the USB cable is securely plugged in at both ends. It is best to plug the CM15A interface directly into a USB port on the back of your computer. If the Interface is plugged into a USB hub, make sure it has power and is not crowded with other devices.

After this, the interface should work. If it does not, open Windows Device Manager (from Control Panel, open System Settings, and click the tab or button labeled "Device Manager"). Look under the list for Universal Serial Bus Controllers.

370.gif


If X10 USB ActiveHome is not listed, unplug the interface from power, and remove its batteries. Then, plug it back in and replace them. Re-initialized, it should now appear in the list.

If using Windows 98, you may need to install the driver again. To do so, right-click on USB ActiveHome and choose "Update Driver." When prompted for the driver files, browse to Program Files\Common Files\X10\Driver Installer\Wireless Transceivers\ and select the files to install.

Set Up A Lamp Module

Follow these steps to set up a lamp module.

  • Turn on the lamp to be controlled.
  • Unplug it from its electrical outlet (while it is still on).
  • Take a look at your lamp module. Make sure that the dials on it are on house code 'A' and unit code '1.'
  • Plug your lamp into the lamp module, and plug the module into an electrical outlet near the ActiveHome Pro USB Interface.

Turn on a Lamp

Now you can test the lamp module for control from ActiveHome Pro software. Flip the switch on the screen to turn the module on and off. If you cannot control the lamp, try the following:

  • Make sure the dials on the lamp module (the House and Unit codes) are set to the same letter and number listed on the module in the ActiveHome Pro software. If they are not, change them and try again.
  • Unplug the lamp from the module and plug the lamp into another electrical socket. If the lamp does not turn on, switch it on, unplug it from the outlet, and plug it into the lamp module again. Now try to turn it on and off from the software screen.
  • Move the lamp module into an electrical outlet closer to the ActiveHome Pro USB interface and try again.
  • Plug the ActiveHome Pro USB Interface and the lamp module into a power strip together to test them.

Once you have one lamp module working, you can try your others. Make sure you enter all of the address information (House and Unit Code) correctly into ActiveHome Pro, and all of the devices you are controlling are turned on before you plug them into modules.

If Some Modules Work and Others Don't

When ActiveHome Pro software is working, you might have trouble controlling all of the modules in your house. In most cases, this problem means that the commands from the USB ActiveHome Interface are not getting through to them. Here is what to do if this happens:

  • Try plugging the ActiveHome USB interface (CM15A) into a different electrical outlet. Then try controlling the module in question. It helps to move the interface to an electrical outlet away from your computer and monitor.
  • Set a timer for one of the modules in question, download it into the interface, and move the interface into a different outlet.
  • Be sure that the lights and/or appliances in use are of the correct type and rating for the X10 modules.
  • Unplug the interface from the wall, and plug a TM751 transceiver module into that outlet. See if you can use a remote control to turn the modules on and off. If you have the same problem, you will need to find another electrical outlet for the interface.
  • Look for electrical appliances near your modules in question, and unplug them. It is possible that something nearby is putting interference on the house wiring, preventing the modules from receiving ActiveHome Pro commands.

Problems with Remote Controls

If you cannot control any modules with your remote controls, but you can control them from the ActiveHome Pro screen, open Hardware Configuration from the Tools menu in ActiveHome Pro. Look in the section at the bottom right entitled "Transceived House Code(s)." Make sure that you set this to Auto, and that the letters of the House Codes you use are all checked. If a House Code you need is not checked, select "Specific" and choose all the correct letters. When all the correct House Codes have been selected, click "Update Interface" to save the new settings.

Since your remote controls use radio-frequency ("RF") signals to communicate with the ActiveHome USB interface, you want to set up the interface it so that it gets the signals loud and clear. Try the following simple steps:

  • Adjust the antenna on the Interface so that it sticks straight out from the body (white box). In many cases this will help significantly.
  • Move the interface to an electrical outlet away from your computer and monitor. Use an extension cord or simple power strip so it sits higher off the ground.
  • Store your timers and macros in the interface; then unplug the USB cable. Sometimes noise from your computer can travel on the USB cable and interfere with radio-frequency reception.

It is also a good idea to check the batteries in your remote control if it has problems sending commands.

Related Articles

Modules Work in Some Locations but not Others

Troubleshooting Remote Controls in ActiveHome Pro

Improving Remote Control Range

Request New ActiveHome Pro Download

ActiveHome Pro Installation Asks for Disk